re = /(^\\\\host1\\teams\\)(?P<Team>[^\\]+)/mi
str = '\\\\host1\\teams\\team1\\bla\\bla\\bla
\\\\host1\\teams\\team2\\bla\\bla
\\\\host1\\teams\\team3\\bla
\\\\host1\\teams\\team4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end