// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(^\\\\host1\\teams\\)(?P<Team>[^\\]+)").unwrap();
let string = "\\\\host1\\teams\\team1\\bla\\bla\\bla
\\\\host1\\teams\\team2\\bla\\bla
\\\\host1\\teams\\team3\\bla
\\\\host1\\teams\\team4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}