import re
regex = re.compile(r"(^\\\\host1\\teams\\)(?P<Team>[^\\]+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\\\\host1\\teams\\team1\\bla\\bla\\bla\n"
"\\\\host1\\teams\\team2\\bla\\bla\n"
"\\\\host1\\teams\\team3\\bla\n"
"\\\\host1\\teams\\team4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")