$re = '/(^\\\\\\\\host1\\\\teams\\\\)(?P<Team>[^\\\\]+)/mi';
$str = '\\\\host1\\teams\\team1\\bla\\bla\\bla
\\\\host1\\teams\\team2\\bla\\bla
\\\\host1\\teams\\team3\\bla
\\\\host1\\teams\\team4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);