#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)<!--((?:(?!-->).)*)-->((?:(?!<!--)[\s\S])+)<!--((?:(?!-->).)*)-->"
Local $sString = "<!-- Text --><b>Text</b>" & @CRLF & _
" <a href="google.com">Link</a>" & @CRLF & _
" <div class="col"><h1>Nested Content</h1><p>More content</p>" & @CRLF & _
" </div>" & @CRLF & _
"<!-- END of Text -->"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)