re = /<!--((?:(?!-->).)*)-->((?:(?!<!--)[\s\S])+)<!--((?:(?!-->).)*)-->/mi
str = '<!-- Text --><b>Text</b>
<a href="google.com">Link</a>
<div class="col"><h1>Nested Content</h1><p>More content</p>
</div>
<!-- END of Text -->'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result