$re = '/<!--((?:(?!-->).)*)-->((?:(?!<!--)[\s\S])+)<!--((?:(?!-->).)*)-->/mi';
$str = '<!-- Text --><b>Text</b>
<a href="google.com">Link</a>
<div class="col"><h1>Nested Content</h1><p>More content</p>
</div>
<!-- END of Text -->';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;