import re
regex = re.compile(r"<!--((?:(?!-->).)*)-->((?:(?!<!--)[\s\S])+)<!--((?:(?!-->).)*)-->", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<!-- Text --><b>Text</b>\n"
" <a href=\"google.com\">Link</a>\n"
" <div class=\"col\"><h1>Nested Content</h1><p>More content</p>\n"
" </div>\n"
"<!-- END of Text -->")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)