#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\w]{3} {1,2}[\d]{1,2} [\d]{4} ([\d]{2}:){3}[\d]{3}(AM|PM)$"
Local $sString = "May 1 2014 12:10:10:000AM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")