const regex = /^[\w]{3} {1,2}[\d]{1,2} [\d]{4} ([\d]{2}:){3}[\d]{3}(AM|PM)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w]{3} {1,2}[\\d]{1,2} [\\d]{4} ([\\d]{2}:){3}[\\d]{3}(AM|PM)$', '')
const str = `May 1 2014 12:10:10:000AM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}