import Foundation
let pattern = #"^[\w]{3} {1,2}[\d]{1,2} [\d]{4} ([\d]{2}:){3}[\d]{3}(AM|PM)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"May 1 2014 12:10:10:000AM"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}