package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\w]{3} {1,2}[\d]{1,2} [\d]{4} ([\d]{2}:){3}[\d]{3}(AM|PM)$`)
var str = `May 1 2014 12:10:10:000AM`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}