$re = '/^[\w]{3} {1,2}[\d]{1,2} [\d]{4} ([\d]{2}:){3}[\d]{3}(AM|PM)$/';
$str = 'May 1 2014 12:10:10:000AM';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);