# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@\[([^\]\s][^\]]+)\]\([^\)]\)/$1/gm;t' <<< "Hello @[Kenneth Auchenberg Saurabh](1) its been long. Tell @[Pete Lacey](6) I will see him tomorrow
"