using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\[([^\]\s][^\]]+)\]\([^\)]\)";
string substitution = @"$1";
string input = @"Hello @[Kenneth Auchenberg Saurabh](1) its been long. Tell @[Pete Lacey](6) I will see him tomorrow
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}