use strict;
my $str = 'Hello @[Kenneth Auchenberg Saurabh](1) its been long. Tell @[Pete Lacey](6) I will see him tomorrow
';
my $regex = qr/@\[([^\]\s][^\]]+)\]\([^\)]\)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";