#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)@\[([^\]\s][^\]]+)\]\([^\)]\)"
Local $sString = "Hello @[Kenneth Auchenberg Saurabh](1) its been long. Tell @[Pete Lacey](6) I will see him tomorrow" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)