// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@\[([^\]\s][^\]]+)\]\([^\)]\)").unwrap();
let string = "Hello @[Kenneth Auchenberg Saurabh](1) its been long. Tell @[Pete Lacey](6) I will see him tomorrow
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}