import Foundation
let pattern = #"@\[([^\]\s][^\]]+)\]\([^\)]\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello @[Kenneth Auchenberg Saurabh](1) its been long. Tell @[Pete Lacey](6) I will see him tomorrow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)