#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\.]*[\d][\s\d]*[\.]*[\d]+)\s([A-Z]{3})"
Local $sString = "любое Ñлово: 5.00 RUR;" & @CRLF & _
"любое Ñлово: 500 125.00 RUR;" & @CRLF & _
"любое Ñлово: .00 RUR;" & @CRLF & _
"любое Ñлово: 0.00 RUR;" & @CRLF & _
"любое Ñлово: 123 500 125.00 RUR;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")