import Foundation
let pattern = #"([\.]*[\d][\s\d]*[\.]*[\d]+)\s([A-Z]{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
любое Ñлово: 5.00 RUR;
любое Ñлово: 500 125.00 RUR;
любое Ñлово: .00 RUR;
любое Ñлово: 0.00 RUR;
любое Ñлово: 123 500 125.00 RUR;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)