$re = '/([\.]*[\d][\s\d]*[\.]*[\d]+)\s([A-Z]{3})/';
$str = 'любое Ñлово: 5.00 RUR;
любое Ñлово: 500 125.00 RUR;
любое Ñлово: .00 RUR;
любое Ñлово: 0.00 RUR;
любое Ñлово: 123 500 125.00 RUR;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);