re = /([\.]*[\d][\s\d]*[\.]*[\d]+)\s([A-Z]{3})/
str = 'любое Ñлово: 5.00 RUR;
любое Ñлово: 500 125.00 RUR;
любое Ñлово: .00 RUR;
любое Ñлово: 0.00 RUR;
любое Ñлово: 123 500 125.00 RUR;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end