using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\.]*[\d][\s\d]*[\.]*[\d]+)\s([A-Z]{3})";
string input = @"любое Ñлово: 5.00 RUR;
люР±Ð¾Ðµ Ñлово: 500 125.00 RUR;
любое Ñлово: .00 RUR;
любое Ñлово: 0.00 RUR;
любое Ñлово: 123 500 125.00 RUR;
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}