using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^A-Za-z0-9 _\-\u00C0-\u024F\u0400-\u04FF\u0374-\u03FF]+)";
string input = @"¿¡ßšœøðϜϘЂç¡ãå_-äê áà98";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}