const regex = /([^A-Za-z0-9 _\-\u00C0-\u024F\u0400-\u04FF\u0374-\u03FF]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^A-Za-z0-9 _\\-\\u00C0-\\u024F\\u0400-\\u04FF\\u0374-\\u03FF]+)', 'g')
const str = `¿¡ßšœøðϜϘЂç¡ãå_-äê áà98`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}