import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^A-Za-z0-9 _\\-\\u00C0-\\u024F\\u0400-\\u04FF\\u0374-\\u03FF]+)";
final String string = "¿¡ßšœøðϜϘЂç¡ãå_-äê áà98";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}