re = /([^A-Za-z0-9 _\-\u00C0-\u024F\u0400-\u04FF\u0374-\u03FF]+)/
str = '¿¡ßšœøðϜϘЂç¡ãå_-äê áà98'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end