using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^a-zA-Z]|\b)word";
string substitution = @"";
string input = @"word 1word !word aword";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}