import re
regex = re.compile(r"([^a-zA-Z]|\b)word")
test_str = "word 1word !word aword"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)