const regex = /([^a-zA-Z]|\b)word/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^a-zA-Z]|\\b)word', 'g')
const str = `word 1word !word aword`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);