$re = '/([^a-zA-Z]|\b)word/';
$str = 'word 1word !word aword';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;