use strict;
my $str = 'word 1word !word aword';
my $regex = qr/([^a-zA-Z]|\b)word/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";