#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m),(?=(?:[^']*'[^']*')*[^']*$)"
Local $sString = "'Field1','Field2','Field3, this field has a comma','Field4'"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)