$re = '/,(?=(?:[^\']*\'[^\']*\')*[^\']*$)/m';
$str = '\'Field1\',\'Field2\',\'Field3, this field has a comma\',\'Field4\'';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;