use strict;
my $str = '\'Field1\',\'Field2\',\'Field3, this field has a comma\',\'Field4\'';
my $regex = qr/,(?=(?:[^']*'[^']*')*[^']*$)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";