#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)--.+$"
Local $sString = "{" & @CRLF & _
""DATE": "2015-11-05"," & @CRLF & _
""array": [" & @CRLF & _
"{" & @CRLF & _
""ERR_ID": "24"," & @CRLF & _
""ERR_MSG":"Сообщение"" & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
""ERR_ID": "25"," & @CRLF & _
""ERR_MSG":"Сообщение"" & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
""ERR_ID": "26"," & @CRLF & _
""ERR_MSG":"Сообщение"" & @CRLF & _
"}" & @CRLF & _
"]" & @CRLF & _
"}--7d50cdce88074cd4a63c326081993246"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")