const regex = /--.+$/mi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('--.+$', 'mi')
const str = `{
"DATE": "2015-11-05",
"array": [
{
"ERR_ID": "24",
"ERR_MSG":"Сообщение"
},
{
"ERR_ID": "25",
"ERR_MSG":"Сообщение"
},
{
"ERR_ID": "26",
"ERR_MSG":"Сообщение"
}
]
}--7d50cdce88074cd4a63c326081993246`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}