using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--.+$";
string input = @"{
""DATE"": ""2015-11-05"",
""array"": [
{
""ERR_ID"": ""24"",
""ERR_MSG"":""Сообщение""
},
{
""ERR_ID"": ""25"",
""ERR_MSG"":""Сообщение""
},
{
""ERR_ID"": ""26"",
""ERR_MSG"":""Сообщение""
}
]
}--7d50cdce88074cd4a63c326081993246";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}