re = /--.+$/mi
str = '{
"DATE": "2015-11-05",
"array": [
{
"ERR_ID": "24",
"ERR_MSG":"Сообщение"
},
{
"ERR_ID": "25",
"ERR_MSG":"Сообщение"
},
{
"ERR_ID": "26",
"ERR_MSG":"Сообщение"
}
]
}--7d50cdce88074cd4a63c326081993246'
# Print the match result
str.match(re) do |match|
puts match.to_s
end