import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "--.+$";
final String string = "{\n"
+ "\"DATE\": \"2015-11-05\",\n"
+ "\"array\": [\n"
+ "{\n"
+ "\"ERR_ID\": \"24\",\n"
+ "\"ERR_MSG\":\"Сообщение\"\n"
+ "},\n"
+ "{\n"
+ "\"ERR_ID\": \"25\",\n"
+ "\"ERR_MSG\":\"Сообщение\"\n"
+ "},\n"
+ "{\n"
+ "\"ERR_ID\": \"26\",\n"
+ "\"ERR_MSG\":\"Сообщение\"\n"
+ "}\n"
+ "]\n"
+ "}--7d50cdce88074cd4a63c326081993246";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}