// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)--.+$").unwrap();
let string = "{
\"DATE\": \"2015-11-05\",
\"array\": [
{
\"ERR_ID\": \"24\",
\"ERR_MSG\":\"Сообщение\"
},
{
\"ERR_ID\": \"25\",
\"ERR_MSG\":\"Сообщение\"
},
{
\"ERR_ID\": \"26\",
\"ERR_MSG\":\"Сообщение\"
}
]
}--7d50cdce88074cd4a63c326081993246";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}