#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^GWDF][0-9DTSRF]+"
Local $sString = "G4 G4 G7 G9 G9 R3 B4 R3 R4 R5 RR W BDT Y0 YS G8 WDF"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)