$re = '/[^GWDF][0-9DTSRF]+/';
$str = 'G4 G4 G7 G9 G9 R3 B4 R3 R4 R5 RR W BDT Y0 YS G8 WDF';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;