// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^GWDF][0-9DTSRF]+").unwrap();
let string = "G4 G4 G7 G9 G9 R3 B4 R3 R4 R5 RR W BDT Y0 YS G8 WDF";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}