import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^GWDF][0-9DTSRF]+";
final String string = "G4 G4 G7 G9 G9 R3 B4 R3 R4 R5 RR W BDT Y0 YS G8 WDF";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}