const regex = /[^GWDF][0-9DTSRF]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^GWDF][0-9DTSRF]+', 'g')
const str = `G4 G4 G7 G9 G9 R3 B4 R3 R4 R5 RR W BDT Y0 YS G8 WDF`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);