using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^GWDF][0-9DTSRF]+";
string substitution = @"";
string input = @"G4 G4 G7 G9 G9 R3 B4 R3 R4 R5 RR W BDT Y0 YS G8 WDF";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}