#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)JOB[\s\w-:]+#(?<job>\w+)\[.+[\s\w=]+\:\s?(?<user>[^\s]+)[\s\w=]+\:\s?(?<script>[^\s]+)[\s\w=]+\:\s?(?<job_number>[^\s]+)[\s\S]+Exit\sStatus\s+\:(?<exit_status>\w+)"
Local $sString = "================================================================" & @CRLF & _
" = JOB : MAXFED33S-LHMX#MDK1997DAILYFTPCONN[(2130 10/31/18),(0AAAAAAAAAAAOBWS)] " & @CRLF & _
" = USER : DOMAIN\khectic " & @CRLF & _
" = SCRIPT : c:\scripts\mdk_copy.bat " & @CRLF & _
" = Job Number: 2484514 " & @CRLF & _
" =============================================================== " & @CRLF & _
" ******************************************************************************************** " & @CRLF & _
" ** copying from " & @CRLF & _
" ** \temp\mdk_temp.csv " & @CRLF & _
" ** to " & @CRLF & _
" ** \target\ " & @CRLF & _
" ** success ** " & @CRLF & _
" ******************************************************************************************** " & @CRLF & _
" =============================================================== " & @CRLF & _
" = Exit Status :OK " & @CRLF & _
" ==============================================================="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")