# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"JOB[\s\w-:]+#(?<job>\w+)\[.+[\s\w=]+\:\s?(?<user>[^\s]+)[\s\w=]+\:\s?(?<script>[^\s]+)[\s\w=]+\:\s?(?<job_number>[^\s]+)[\s\S]+Exit\sStatus\s+\:(?<exit_status>\w+)"
test_str = ("================================================================\n"
" = JOB : MAXFED33S-LHMX#MDK1997DAILYFTPCONN[(2130 10/31/18),(0AAAAAAAAAAAOBWS)] \n"
" = USER : DOMAIN\\khectic \n"
" = SCRIPT : c:\\scripts\\mdk_copy.bat \n"
" = Job Number: 2484514 \n"
" =============================================================== \n"
" ******************************************************************************************** \n"
" ** copying from \n"
" ** \\temp\\mdk_temp.csv \n"
" ** to \n"
" ** \\target\\ \n"
" ** success ** \n"
" ******************************************************************************************** \n"
" =============================================================== \n"
" = Exit Status :OK \n"
" ===============================================================")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.